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ACCESSIBILITY IN INDESIGN

Understanding InDesign and taking advantage of best practices will do 
the heavy lifting when it comes to creating accessible documents.

Beginner

Learning 
Curve for 
Creating 

Accessible 
Documents

InDesign Skills

Advanced



Copyright ©2019 Gratzer Graphics LLC. No content may be reproduced or altered in any medium without written permission of Gratzer Graphics LLC. 

3

Control everything with a style—no formatting from the toolbar!

Some accessibility tasks may have more than one approach. Others 
may require some creative thinking.
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PARAGRAPH STYLES

With no documents open (so these become your default styles), 
create paragraph styles and assign export tags.

2

1
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•	Basic paragraph (or custom body text style): set to P;
•	Headings (6 possible levels): set to H1…H6, respectively;
•	Bulleted list: set to Automatic;
•	Numbered list: set to Automatic;
•	Blockquote: set to Automatic;
•	Table of contents: set to Automatic.

Export tags define how the text should be tagged 
when exported to PDF. It’s helpful to name them 
with their corresponding HTML tags.

Styles set to Automatic may need to be manually changed in Acrobat.
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Make use of the Based On feature to make styling more efficient:

1.	Duplicate an existing style.

2.	Rename the style.

3.	Changed the Based On settings.

4.	Style as desired.

1 2 3 4
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CHARACTER STYLES

Create your default character styles.
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TABLE & CELL STYLES

Create cell and table styles to set your default styles.
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OBJECT STYLES

Create object styles to set your default object styles.
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ARTIFACTING: TEXT

Artifacts are elements that are ignored by 
screen reading devices and other assistive 
technologies. Any elements that don’t 
convey information or aren’t essential 
should be artifacted.

Apply artifacting to paragraph styles for 
any text elements that should be artifacted:

•	Page numbers and
•	Running headers and footers.
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ARTIFACTING: OBJECTS

Apply artifacting to object styles for any 
elements that should be artifacted:

•	Decorative blocks of color,
•	Decorative elements such as rules,
•	Decorative background graphics.
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You can also artifact an element by right-clicking (Mac) or control-
clicking (PC) and selecting Object Export Options and selecting 
Tagged PDF > Artifact.

1

2
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COLOR

Do not convey information by color alone. Distinguish with tags and 
differences in size, font weight, styling, etc.
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Check contrast with a color contrast 
checker such as WebAIM. 

WCAG Level AA requires a contrast 
ratio of at least:

•	4.5:1 for normal text,
•	3:1 for large text.

WCAG Level AAA:

•	7:1 for normal text and
•	4.5:1 for large text.
Large text is defined as 14 point and bold or larger, or 18 point or larger.

https://webaim.org/resources/contrastchecker/
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DOCUMENT SETUP

Create a new document with a Primary 
Text Frame to automatically create 
threaded stories. 

You can also:

•	create one frame per column of text.
•	use a single frame per page with 

multiple columns.
•	thread frames together.
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MASTER PAGES

Create master pages with text frame(s).

•	Text frames should reach to pink and 
purple guides, not aligned to added 
guides.
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•	Do not override master page items. Create new 
nested master pages instead:

1.	Duplicate the master page.

2.	Drag and drop a master over the 
duplicated one.

3.	Select All and delete the items on the newly 
created master page and modify as needed.

•	Artifact running headers/footers (paragraph style 
or on text frame with object style), rules and 
design elements.

2

3
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TEXT

Typefaces and Characters
Choose OpenType fonts and use Unicode 
characters for such symbols as a copyright 
symbol or fractions.

Importing
Mapping styles or stripping out all formatting 
(importing text with Show Import Options checked) 
prevents Word code from getting into the layout 
and causing problems when the PDF is created.
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Threading
•	Thread all text frames, or only 

individual sections or chapters.

•	Leave the table of contents 
unthreaded from the rest of the 
document’s content.
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Cleaning Up
•	Remove multiple spaces and 

paragraph marks.

•	Remove any forced breaks. 
Use a “no break” style instead.

•	Remove tabs.

•	Rekey anything in all caps 
unless an acronym. OK to style 
as all caps.

•	Change hyphens that should 
be en or em dashes (no double 
hyphens).

•	Check that symbols such as 
copyright and fractions conveyed. 
Rekey with Unicode characters.

•	Remove blank rows and 
columns in tables; merge cells 
where needed.
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Formatting Text
Control everything with a style—no formatting from the toolbar! 
Formatting from the toolbar results in style overrides, which may 
prevent some AT from presenting the info to their users.
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Instead, create new paragraph or character 
styles based on other styles to make 
adjustments, including tracking, so you have no 
overrides anywhere.

Example: To have a heading start on the next 
page, instead of inserting several paragraph 
marks or a page break, create a style called “H3 
next page” based on the original and set the 
Keep option to Start on Next Page.
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•	Set the export tag of the paragraph 
style of the document title as H1. Style 
chapter or section titles as H1 or H2.

•	Use the correct sequential order for 
headings and do not skip any, such as 
do not go from an H2 to an H4.

•	Take advantage of paragraph styling 
options such as Span Columns, 
Paragraph Shading and Paragraph 
Rule, etc.

H2
H1

H3

H3

H2
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GRAPHICS

•	Anchor images in the text at the end 
of the paragraph in which they are 
mentioned.

•	Apply object style.

•	Rewrite any text referencing relative 
positioning (“below” or “above”). 
Instead, use an absolute reference 
such as “See Figure 1.”
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Alt-Text
Images and images of text cannot be read by screen readers.

Add Alt-text, which does get read, to non-decorative images. Right-
click (Mac) or control-click (PC) and select Object Export Options. 

1

2
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•	Alt-text should say what the 
image contains, key visual 
elements. Do not give more 
info than a sighted reader 
will get.

•	Do not repeat the same info as 
in the caption.

•	For infographics, explain what 
they represent and provide 
the data (if short) or link to a 
matching data table (after the 
chart graphic, in an appendix or 
on a website) where that data 
might be provided.
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Graphs, Charts and Maps
They may require more attention to 
ensure readability and sufficient contrast 
between colors and against backgrounds.

Check contrast with a color-blindness 
simulator such as Coblis — Color 
Blindness Simulator.

https://www.color-blindness.com/coblis-color-blindness-simulator/
https://www.color-blindness.com/coblis-color-blindness-simulator/
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You cannot convey information by color 
alone, so if contrast is not sufficient to 
distinguish the various elements by color, 
use other means:

•	Use lines with shapes in a line graph.

•	Use differing patterns in the pieces of a 
pie chart or bar graph.

•	With maps, put text that appears on top 
of the map in a contrasty color or bold, 
add a slight drop shadow or move the 
text outside the map.



Copyright ©2019 Gratzer Graphics LLC. No content may be reproduced or altered in any medium without written permission of Gratzer Graphics LLC. 

29

TABLES

•	Anchor the table in the text.

•	Place the title above/outside of 
the table.

•	Style table headers.

•	Style table cells with paragraph 
styles that have Export Tagging set 
to Automatic.
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•	Add/convert top row(s) to proper header row(s).

•	Remove blank rows or columns.

•	Place footnotes after the table. CC 2019 places 
footnotes at the bottom of the frame that holds the table 
(which should be in its own frame).

•	Do not span across 2 pages unless using columns.

•	OK to place table in its own frame anchored in the text.

•	OK to use View > Rotate Spread for pages to 
accommodate wide tables.
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SIDEBARS

•	Create sidebars and anchor them in 
the text at the end of the paragraph 
in which they’re mentioned.

•	Style sidebar titles as H2 or another 
level of heading based on the 
logical order in which they fall in the 
section.
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•	Use Apply Next Style under an object’s 
paragraph styles to style multiple paragraphs 
at a time when the next style has been set in 
that paragraph style.

•	A sidebar of only one paragraph could be 
styled within the same text frame simply using 
Paragraph Shading.
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HYPERLINKS

Make all links (hyperlinks, e-mails, footnotes, 
etc.) clickable.

•	Convert URLs to hyperlinks and manually 
hyperlink other links: Type > Hyperlinks & 
Cross-References > Convert URLs to 
Hyperlinks.
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•	Create Hyperlink Destinations for cross-
references. Then go to their respective 
references in the text, highlight them 
and link to them.

•	Manually link superscripted mentions 
and footnotes.
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TABLE OF CONTENTS

•	Create TOC paragraph styles:
•	Set Export Tagging of TOC title as H2 

and regular TOC text as Automatic.
•	Create TOC using the built-in feature, 

which will create a clickable TOC.
•	In Layout > Table of Contents, set up the 

TOC styles based on heading styles.
•	Add bookmarks for all covers, chapters 

and sections easily by selecting Create 
PDF Bookmarks.



Copyright ©2019 Gratzer Graphics LLC. No content may be reproduced or altered in any medium without written permission of Gratzer Graphics LLC. 

36

READING ORDER

Text must have a logical reading 
order. What you see in InDesign is not 
necessarily the order in which it will 
be read in the PDF.

Articles Panel
•	Drag and drop the TOC and the main 

content (or multiple unthreaded 
sections) into the Articles panel.

•	Check the option to Use for Reading 
Order in Tagged PDF.
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Layers
Reorder items within the same layer 
(drag and drop) as opposed to creating 
new layers.

This text frame containing “2018” visually appears 
above the text frame containing “Annual Report…” 
and gets read in that order by a screen reader 
because the text frame with “2018” is below the 
text frame with “Annual Report…” in the Layers 
panel (which is read bottom to top).
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•	Article panel is read from top down.
•	Layers panel is read from bottom to top.
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METADATA

Add metadata at any time in the 
process in InDesign: File > File Info.

•	Fill out at least the Title, Author, 
Description and Keywords fields.

•	The Description field will get read 
by search engines, so the first 150 to 
200 words are most important.

•	Add as many keywords as you want.
•	Don’t use “&” if title has “and.” Limit 

use of ampersands.
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PREFLIGHT & CHECKS

•	Preflight as usual.

•	Turn on the Style Override Highlighter 
and check for any style overrides 
highlighted in the text and denoted 
with a “+” sign in the style palette.

•	Check status of hyperlinks 
and replace any broken links.

2

1
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•	Check tags: Paragraph Styles palette > Edit All Export Tags. 
Modify if needed.
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EXPORT

Export as PDF (Interactive).

General Settings
•	Export as Pages, not Spreads, so 

the reading order in the PDF is 
not affected.

•	Layout: Single Page.
•	Check Create Tagged PDF.
•	Check Use Structure for Tab Order.
•	Forms and Media: Include All.
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Compression
Set the resolution.

•	Set the downsampling to 144 PPI, 200 PPI or 
300 PPI, depending on the type of images.

•	Optionally increase the Image Quality setting 
to High or Maximum.

The higher the resolution, the greater the file 
size of the PDF.

Export a separate PDF file for printing with 
Export (Print).
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ACROBAT

1.	If you didn’t check Use Structure 
for Tab Order: Organize Pages > 
Select All > More > Page 
Properties > Use Document 
Structure.

2.	Run Full Accessibility Check.

3.	Edit the role map if needed, 
using the correct allowed tags.
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4.	Troubleshoot and go back and fix issues 
in InDesign if needed (you may need to 
check the Layers and Articles panels). Then 
re-export and redo steps 1 and 2.

5.	Check metadata and remove leading 
semicolon in keywords.

6.	In File > Properties, set Initial View to 
Bookmarks Panel to open when file is opened.

7.	Set page view as two-up if desired.

8.	Save the PDF.
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INDESIGN BUG

Using a custom Unicode character for bulleted 
lists, rather than the default bullet, results in:

•	a double <Span> tag in the tagged PDF’s 
<Lbl> tag, causing the bullet character to be 
voiced twice.

•	the space between the bullet and text appear 
first, instead of the bullet first.
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Solution
•	Use the default bullets.

•	If using a custom bullet, either artifact the space’s <Span> in Acrobat 
or allow the double voicing of the bullet. It’s not a barrier, but 
a nuisance.

You can vote for these and other bugs to be fixed at InDesign.
uservoice.com. Visit PubCom’s webpage to learn which items to 
vote for.

https://indesign.uservoice.com/
https://indesign.uservoice.com/
https://www.pubcom.com/vote/
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CONTACT INFO

Branding, publications 
and accessibility

•	design@gratzergraphics.com

•	LinkedIn

•	GratzerGraphics.com

Resources and Design 
Domination podcast 
for designers

Creative-Boost.com

PubCom
Training by PubCom

mailto:design%40gratzergraphics.com?subject=DOI%20508%20presentation
https://www.linkedin.com/in/gratzergraphics/
https://gratzergraphics.com
https://creative-boost.com/podcast/
https://creative-boost.com/podcast/
http://creative-boost.com
https://www.pubcom.com/
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